Skip to main content

Prior Authoirzation Requirements

We are updating specific authorization requirements for Medicare.

For dates of service on or after December 15, 2018, we are requiring our providers to obtain authorization for the two medications listed below. At this time, no other changes to WellCare’s authorization rules are changing. 

J7198 Anti-inhibitor, Per IU

J2507 Injection, Peglocticase, 1mg

On December 15, 2018, www.wellcare.com/auth_lookup will be updated to reflect these changes. Prior authorization requirements are subject to periodic changes. You should always use our website’s authorization page to determine whether a procedure code requires prior authorization, and always check eligibility and confirm benefits before rendering services to members. Failure to do so may result in denial of reimbursement. 

For questions regarding this notice, please contact Provider Services at the number located in your Quick Reference Guide. When prompted say “Authorizations” or press 2.

Thank you for your continued participation and cooperation in our ongoing efforts to render quality healthcare for our members. We look forward to helping you provide the highest quality of care for our members.

Ícono de contacto

¿Necesita ayuda? Puede contar con nosotros.

Contáctenos
Última actualización: 11/9/2018
On April 22, 2024, UnitedHealth Group issued a press release, providing an update on the Change Healthcare cybersecurity incident that occurred on Feb. 21, 2024. Given the size of the data impacted, the investigation to determine whose data is impacted is expected to take several months. UnitedHealth Group believes this situation will impact “a substantial proportion of people in America” and is offering immediate credit monitoring and identity protection services, as well as a dedicated contact center to address questions. Visit Change Healthcare Cyberattack Support and/or reach out to the contact center at 1-866-262-5342 regarding any questions.

×